<!DOCTYPE html>
<html lang='en'>
<head>
<title>Riverton outpatient facility graduates four individuals to life-long recovery | South Valley Journal</title>
<meta charset='utf-8'>
<meta content='LocablePublisherNetwork.com' name='generator'>
<meta content='width=device-width, initial-scale=1' name='viewport'>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"cc2c1fbc9a","applicationID":"18721","transactionName":"IQwNRUJXWQhdEBdZRxYKAF1VSxoXUA1P","queueTime":2,"applicationTime":141,"agent":""}</script>
<script>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</script>
<meta content='122882951100578' property='fb:app_id'>
<meta property="og:title" content="Riverton outpatient facility graduates four individuals to life-long recovery | South Valley Journal" /><meta name="description" content="In 2010 Dr. Joseph White started the Foundation for Family Life, an outpatient treatment facility in Riverton for individuals suffering from things ranging all the way from substance and alcohol addiction to issues experienced in marriage and fami..." /><meta property="og:description" content="In 2010 Dr. Joseph White started the Foundation for Family Life, an outpatient treatment facility in Riverton for individuals suffering from things ranging all the way from substance and alcohol addiction to issues experienced in marriage and fami..." /><meta property="og:type" content="article" /><meta property="og:image" content="http://locable-assets-production.s3.amazonaws.com/uploads/resource/file/933250/Foundation_20for_20Family_20Life_20Graduate_20Photo_20-_20Wilcox__20Dylan.jpg?timestamp=1656690855" /><meta property="og:image:width" content="4000" /><meta property="og:image:height" content="3000" /><link rel="canonical" href="https://www.rivertonjournal.com/2022/07/01/404766/riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery" /><meta property="og:url" content="http://www.rivertonjournal.com/2022/07/01/404766/riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery" /><meta name="keywords" content="Today, Local Life, July 2022" /><meta name="ICMB" content="" />

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="TE1H80F6A6FZDzVKd4+adGyvWN3/GirBUP6tMi2L0kPJT4n5Zv7T/ONi5Mcge08EhCsvjegCrcRZ7wn+2RaSRg==" />
<link rel="shortcut icon" type="image/x-icon" href="//cdn3.locable.com/uploads/favicon_img/file/39/CJ_Favicon-32x32.png" />
<link rel="stylesheet" media="screen" href="//cdn1.locable.com/assets/application-e9968553883ec0da0533edff74ff99b362e4b2e0ec5566d1c07106800206bcdd.css" />
<link rel="stylesheet" media="print" href="//cdn3.locable.com/assets/print-fe1b40859b2ebf3b0a55c395ad974b40f3dc0afb58a59f937c6ab67b342c3f65.css" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
</script>
<script>
  ga('create', 'UA-62910614-1', 'auto');
  ga('send', 'pageview');
</script>
<script>
  ga('create', 'UA-16494411-5', 'auto', {'name': 'rollup'});
  ga('rollup.send', 'pageview');
</script>
<style>
  .custom-header, .custom-header a {color: #ffffff !important; }.custom-header {background-color: #007051 !important; }.custom-header {text-align: center !important; }#main-nav .navbar-nav .nav-link, .classic-nav .navbar-brand .navbar-text, #main-nav .navbar-toggler span {color:  !important;} #main-nav .navbar-toggler {border-color:  !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {color: #ffffff !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {background-color: #007051 !important;}.public #main-nav .container, .dco #main-nav .container, .admin #main-nav, .admin #main-nav .container {background-color:  !important;}#main-nav .dropdown-item {color:  !important;}#main-nav .dropdown-item:hover {color:  !important;}#main-nav .dropdown-item:hover {background-color:  !important;}#main-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {color: #ffffff !important;}#secondary-nav .navbar-nav .nav-link:hover, #secondary-nav a:hover {color: #007051 !important;}#secondary-nav .navbar-nav .nav-link:hover, #seconary-nav a:hover {background-color: #ffffff !important;}#secondary-nav nav {background-color: #007051 !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {background-color:  !important;}#secondary-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {font-size: 1.2rem !important; line-height: 1.2rem; letter-spacing: 1.5px;}.col-menu li a, .simple-footer li a, #copyright p.text-muted a {color:  !important; }.col-menu li a:hover, .simple-footer li a:hover, #copyright p.text-muted a:hover {color: #007051 !important; }#footer p, #footer h6, #copyright p {color:  !important; }.places #copyright, .places #footer, #copyright .container, #footer .container {background-color:  !important; }
</style>
<style>
  
</style>
<meta name="google-site-verification" content="w4B26YBivWvg007bxK2P1YaQirePoFlddfNTpjCv7aM" />
<script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js?ts=1656676800'></script></head>


<body class='classic-header public'>
<a class="sr-only" href="#content">Skip to main content</a>
<div class='fixed-top' data-toggle='affix'>
<section id='main-nav'>
<div class='container theme-shadow bg-white'>
<nav class='classic-nav navbar navbar-expand-lg navbar-light'>
<a class="navbar-brand" href="/"><span class='navbar-text fas fa-home' style='position:relative;top:2px'></span>
</a><button aria-controls='navbarContent' aria-expanded='false' aria-label='Toggle navigation' class='navbar-toggler' data-target='#navbarContent' data-toggle='collapse' type='button'>
<span class='fas fa-bars'></span>
</button>
<div class='collapse navbar-collapse' id='navbarContent'>
<ul class='navbar-nav mr-lg-auto' style='white-space: nowrap;'>
<li class='nav-item page-60529-nav'><a class="nav-link" href="/pages/aboutus">About Us</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-60537-nav'><a class="nav-link" href="/pages/advertise">Advertise</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-92573-nav'><a class="nav-link" href="/pages/rack-locations">Rack Locations</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-114340-nav'><a class="nav-link" href="/pages/more-journals">More Journals</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-60545-nav'><a class="nav-link" href="/pages/contactus">Contact Us</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-345206-nav'><a class="nav-link" href="/pages/write-for-us">Write For Us</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='external-link-231-nav nav-item'><a class="nav-link" href="https://www.rivertonjournal.com/archives">E-Edition</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<div class='dropdown-divider d-inline d-lg-none'></div>

<div class='d-lg-none'>
<li class='category-134-nav nav-item theme-menu-toggle' data-toggle='category-134'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav nav-item theme-menu-toggle' data-toggle='category-425'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav nav-item theme-menu-toggle' data-toggle='category-636'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav nav-item theme-menu-toggle' data-toggle='category-423'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav nav-item theme-menu-toggle' data-toggle='category-776'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-101-nav nav-item theme-menu-toggle' data-toggle='category-101'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='category-104-nav nav-item theme-menu-toggle' data-toggle='category-104'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='calendar-nav nav-item theme-menu-toggle' data-toggle='calendar'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='directory-nav nav-item theme-menu-toggle' data-toggle='directory'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

<div class='dropdown-divider'></div>
</div>
<div class='d-lg-none'>
<!-- = link_to image_tag('locable-l-icon.png', alt: 'Locable'), :root, class: 'navbar-brand hidden-xs' -->
<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>

<div class='dropdown-divider'></div>
</div>
</ul>
<ul class='navbar-nav ml-lg-auto'>
<ul class='list-inline social-links' style='white-space: nowrap;'>
<li class='list-inline-item mr-2'>
<a target="_blank" class="facebook" href="https://www.facebook.com/SouthValleyJournal/"><i class='fab fa-facebook fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="instagram" href="https://instagram.com/cityjournals"><i class='fab fa-instagram fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="linkedin" href="https://www.linkedin.com/company/city-journals/"><i class='fab fa-linkedin fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="twitter" href="https://twitter.com/SValleyJournal"><i class='fab fa-twitter fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="email" href="/pages/contactus"><i class='fas fa-envelope fa-2x'></i>
</a></li>
</ul>

<form class="form-inline" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" />
<div class='input-group'>
<label class="sr-only" for="q">Search</label>
<input type="text" name="q" id="q" placeholder="Search Site" class="form-control" />
<span class='input-group-btn'>
<button class='btn btn-secondary btn-search'>
<span class='sr-only'>Search</span>
<span class='fas fa-search'></span>
</button>
</span>
</div>
</form>


</ul>
</div>
</nav>
</div>
</section>
</div>

<section id='alerts'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>

</div>
</div>
</section>
<header>
<section id='masthead'>
<div class='container theme-shadow bg-white'>
<div class='row'>
<div class='col-12'>
<h1 class='p-3'><a href="/"><img alt="South Valley Journal" style="max-width: 100%;" src="//cdn0.locable.com/uploads/logo_image/file/412/CJ-Website_Riverton.png" /></a></h1>
</div>
</div>
</div>
</section>

<div class='d-none d-lg-inline'>
<section id='secondary-nav'>
<div class='container theme-shadow bg-white'>
<div class='row py-1'>
<div class='col-sm-12'>
<nav class='navbar navbar-expand-lg navbar-light'>
<!-- %ul#theme-navigation-tabdrop-menu.navbar-nav.mr-auto -->
<ul class='navbar-nav mr-auto flex-wrap' style='white-space: nowrap;'>
<!-- %li.pull-left -->
<!-- = link_to :root do -->
<!-- - if current_site.homepage.present? -->
<!-- = current_site.homepage -->
<!-- - else -->
<!-- %span.fa.fa-home{style: 'font-size:14px;position:relative;top:-1px'} -->
<li class='category-134-nav nav-item theme-menu-toggle' data-toggle='category-134'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav nav-item theme-menu-toggle' data-toggle='category-425'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav nav-item theme-menu-toggle' data-toggle='category-636'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav nav-item theme-menu-toggle' data-toggle='category-423'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav nav-item theme-menu-toggle' data-toggle='category-776'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-101-nav nav-item theme-menu-toggle' data-toggle='category-101'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='category-104-nav nav-item theme-menu-toggle' data-toggle='category-104'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='calendar-nav nav-item theme-menu-toggle' data-toggle='calendar'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='directory-nav nav-item theme-menu-toggle' data-toggle='directory'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

</ul>
</nav>
</div>
</div>
</div>
</section>

</div>
<section id='pushdown'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>
<div class='py-3'><broadstreet-zone
        zone-id='pushdown'
        keywords='articles, article_riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery, south-valley-journal'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='pushdown'
                  keywords='articles, article_riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery, south-valley-journal'>
                  </broadstreet-zone></div>
</div>
</div>
</section>
</header>
<div class='container theme-shadow bg-white' id='content'>
<div class='row'>
<div class='col-12 col-lg-8'>
<section id='admin-buttons'>
<div class='container'>
<div class='row'>
<div class='col-12'>
<div class='btn-group btn-group-sm'>
</div>
</div>
</div>
<div class='row py-2'>
<div class='col-12'>
</div>
</div>
</div>
</section>
<article>
<div class='container'>
<div class=''>
<div class='row py-3'>
<div class='col-12'>
<h1 class='py-0'>
Riverton outpatient facility graduates four individuals to life-long recovery
</h1>
<span class='small text-muted'>
Jul 01, 2022 09:43AM
&#x25CF
By Dylan Wilcox
</span>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='images-contain'>
<img class="img-fluid" src="//cdn3.locable.com/uploads/resource/file/933250/fill/800x600/Foundation_20for_20Family_20Life_20Graduate_20Photo_20-_20Wilcox__20Dylan.jpg?timestamp=1656690202" />
</div>
</div>
</div>
<div class='d-flex justify-content-center'>
<div class='py-3 broadstreet'>
<broadstreet-zone
        zone-id='sponsored'
        keywords='articles, article_riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery, south-valley-journal'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='sponsored'
                  keywords='articles, article_riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery, south-valley-journal'>
                  </broadstreet-zone>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='clearfix images-contain images-thumbnails'>
<p>By Dylan Wilcox | <a href="/cdn-cgi/l/email-protection#3a5e144d53565955427a574359534e4350554f48545b564914595557"><span class="__cf_email__" data-cfemail="3d59134a54515e52457d50445e5449445752484f535c514e135e5250">[email&#160;protected]</span></a></p>

<p>In
2010 Dr. Joseph White started the Foundation for Family Life, an outpatient
treatment facility in Riverton for individuals suffering from things ranging
all the way from substance and alcohol addiction to issues experienced in
marriage and family relationships. Since its founding 12 years ago, the
Foundation has provided support and life coaching for dozens of individuals and
their families. On May 27, four individuals graduated from the 6-month program.</p>

<p>Will
Toon, Josh Anderson, Sateki Lao and Joseph Villalobos each were presented a
plaque indicating their completion of the Foundation’s Redwood Recovery program,
which aims to help participants to set a life of complete and total sobriety. White
acknowledged that this program is not for everyone, but he attested to the
effectiveness of it.</p>

<p>“The
Foundation for Family Life has developed two programs specifically for those
with substance abuse challenges transitioning from incarceration.  These
programs are designed to equip those who want to change with the tools and
resources necessary to make sustainable, lasting change.  We never push;
we only invite.  In fact, clients often come back if they aren’t ready the
first time around,” White said. White says that their approach is
individual-focused, meaning that they will work on helping each person with
their own unique struggles and circumstances. “The overarching goal from the
creation of these programs has been to provide the most effective tools,
resources and environments in which successful recovery can happen,” he added.</p>

<p>The
Foundation’s purpose, as written in its framework, is “to help families and
individuals learn, practice, and commit to health communication, effective
parenting, enriched relationship skills and lasting recovery.” And its mission
is “to empower individuals and families to improve their lives through quality
programs and services." </p>

<p>Will
Toon, one of the program’s graduates, said he is grateful for being able to
complete the program. Toon experienced bouts with addiction and run-ins with
law enforcement which created an untenable life for both himself and his
family. After living in New Hampshire, he decided to relocate to Utah to get
away from the rebellious lifestyle he decided to leave behind.</p>

<p>“I
never thought I would complete this program, I never thought I would be sober,”
Toon said. “I was able to turn it all around through this program. I was able
to find a job, put time in a company, and stop drinking. I recommend this
program to people who are serious about recovering,” he added.</p>

<p>Jennifer
Toon, Will’s mother, said it was very difficult to deal with Will’s struggle
with alcoholism and encounters with police. She said she didn’t play a specific
role in Will’s recovery but knew that she had to continue to support him
through his journey, no matter how difficult that journey would be.</p>

<p>“I
had to set my boundaries, but luckily all the growth has been for the positive,”
she said. The Toons unfortunately lost a daughter to addiction but believe that
this program helped to save their son. “Will lost a sister who died when she
was 25. We all have those addictive behaviors that we have suffered from, but I
am so proud of Will, and I hope he’ll continue to stick to [his recovery],”
Jennifer Toon said.</p>

<p>Will’s
older sister, Aubrey, was deeply moved when Will got up to speak in front of
the room packed with people about his recovery. “I am just really proud of you,
Will,” Aubrey said. “It was a lot of stress on our family for a lot of years.
You came out determined to be different and to change and you really, really
have,” she added. Aubrey’s relationship with Will has changed for the positive,
even saying their ability to communicate together has improved.</p>

<p>Will’s
father, Bill Toon, echoed his family’s sentiments about Will’s recovery. Bill
said it was very difficult to deal with the challenges their family experienced,
having experienced a couple family members passing away, namely Bill’s father
and his daughter. The struggles that Will had compounded to an even more
difficult time period for their family.</p>

<p>“Those
were unbearable years, Will was in and out of jail, in and out of lawyers,”
Bill said. “I lost my father, I lost my daughter, and Will was in and out of
prison. It gets to a point where you say, ‘You can’t do it all, you’ve got to
do this on your own.’ This is the first time that I’ve heard Will have
self-reflection that this is his issue, not everybody else’s. I’m very proud of
him that he’s taken ownership,” Bill added.</p>

<p>Alec
Beaulieu, Will’s friend and mentor, flew out from Portland, Maine to celebrate
Will’s sobriety milestone with him in person. Alec and Will lived together as
roommates in New Hampshire. “The Will today is totally different from the Will
I knew six years ago,” Beaulieu said. “Back in the day, Will would fall apart
at the drop of a hat. He would be very angry, but today he’s much calmer and
more rational,” he said. Beaulieu said their friendship was rocky because of
Will’s argumentative attitude. “Will is calmer, he’s a calm person now. We used
to argue a lot back in the day, but now it’s different,” Beaulieu said. Bill
joked that their friendship sounds like “a working marriage” now.</p>

<p>Josh
Anderson began his program in August 2021 and nearly 8 months later, he
successfully completed the program. Anderson learned about the Foundation’s
program through a probation officer. He said this program was different, having
been through a couple other addiction interventions in the past.</p>

<p>“I’ve
been through four or five different programs I just couldn’t graduate,”
Anderson said. He said that the other programs were difficult to get past after
60 days from a combination of the strictness of the plan and his own decisions.
After deliberating his options with his probation officer, the officer suggested
Anderson undergo the Foundation for Family Life’s program.</p>

<p>“[The
Foundation] is willing to work with you. Other programs have a two-strike rule.
This program will work with you. If you relapse, they’ll work with you. They’ll
take you to an inpatient detox as long as you want to do it. That’s the biggest
difference I would say,” Anderson added. He said that White’s team was “very
supportive” of everyone in the program. He cited the team’s welcoming
camaraderie and understanding point of view, given that some members of the
Foundation’s team have experienced being in prison.</p>

<p>Ray
Flitton, a current participant in the Foundation’s program, says the program
has been a positive experience thus far. Flitton has been in the process for
two months, even becoming a House Lead to “keep an eye on things, make sure
there’s no problems” at the facility.</p>

<p>“This
has been a blessing,” Flitton said. “They do focus on the subject of families.
And as men, we sometime lose our way, but [the program] gives us the tools to
lead a healthy and fulfilling life again,” he said. Flitton said this program
has helped him immensely, based on his experience with two other programs
before. He cites the Foundation’s mentorship and ability to help participants
without being overbearing in the process. Flitton dealt with homelessness as a
result of his alcoholism, but finding his way back through the program has been
a lifesaver for him and his family.</p>

<p>Flitton,
a diesel mechanic who worked on heavy machinery, said his wife and kids have
been supportive throughout his time with the Foundation. He has viewed the
program as a new lease on life and is strongly considering becoming a mentor to
help others in a similar situation as he was in. “I just really admire what they’re
doing and we need more people to do this, the need is there,” he said.</p>

<p>For
more information about the Foundation’s work, visit <a href="https://rr.fflut.org/">https://rr.fflut.org/</a> </p>

<p> </p>

<p> </p>
</div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='addthis_native_toolbox'></div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<span class='fas fa-tags' style='margin-right: 2px'></span>
<a style="color: #555" href="/categories/today">Today</a>, <a style="color: #555" href="/categories/local-life">Local Life</a>
<a style="color: #555" href="/article_tags/july-2022">July 2022</a>

</div>
</div>
<div class='row py-3'>
<div class='col-12'>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='fb-comments' data-href='http://www.rivertonjournal.com/2022/07/01/404766/riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery' data-width='100%'></div>
</div>
</div>
</div>
</div>
</article>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  var addthis_share = {
     url: "https://www.rivertonjournal.com/2022/07/01/404766/riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery",
     title: "Riverton outpatient facility graduates four individuals to life-long recovery",
     description: "In 2010 Dr. Joseph White started the Foundation for Family Life, an outpatient treatment facility in Riverton for individuals suffering from things ranging all the way from substance and alcohol addiction to issues experienced in marriage and family relationships.",
     media: "//cdn1.locable.com/uploads/resource/file/933250/fill/1200x600/Foundation_20for_20Family_20Life_20Graduate_20Photo_20-_20Wilcox__20Dylan.jpg?timestamp=1656690855"
  }
</script>

</div>
<div class='col-12 col-lg-4'>

<div class='div' style='width: 300px; margin: auto;'>
<div class='images-sidebar my-3 clearfix'>
<div class="image-medium"><img alt="" src="//cdn0.locable.com/uploads/resource/file/914199/fill/300x0/Intermountain-TreePlanting-Web-v2.png?timestamp=1649878717"><br></div><p>&nbsp;</p>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class='undecorate'>
<div class='my-3'>
<h5 class='px-3 py-2 custom-header'>Upcoming Events Near You</h5>
</div>
</div>
<div id='calendar-widget'>
<div class='undecorate'>
<div class='my-3'>
<a class="undecorate" href="/events/234835/gem-faire"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
1
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Gem Faire
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00pm
&#183;
Mountain America Expo Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/234832/gem-faire"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
1
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Gem Faire
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00pm
&#183;
Mountain America Expo Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/234834/gem-faire"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
1
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Gem Faire
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00pm
&#183;
Mountain America Expo Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/234836/gem-faire"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
1
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Gem Faire
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00pm
&#183;
Mountain America Expo Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/234835/gem-faire"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
2
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Gem Faire
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00pm
&#183;
Mountain America Expo Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/234832/gem-faire"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
2
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Gem Faire
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00pm
&#183;
Mountain America Expo Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/234834/gem-faire"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
2
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Gem Faire
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00pm
&#183;
Mountain America Expo Center
</div>
</div>
</div>
</div>
</div>
</div>
</a>
<div class='d-flex justify-content-center pb-3'>
<a class="btn btn-light" href="/calendar"><div class='fas fa-calendar-alt'></div>
View All
</a><a class="btn btn-light rounded-0" href="/events/new"><div class='fas fa-plus-circle'></div>
Add Your Event
</a></div>
</div>
</div>
</div>

</div>
<div class='images-sidebar my-3 clearfix'>
<div class='py-3 sidebar-current-issue'>
<a style="text-decoration: none" href="/2022/06/03/402206/in-this-issue-june-2022"><div class='row'>
<div class='col-12'>
<h3 class='text-uppercase' style='color:#0c9157'>
JUNE
</h3>
</div>
</div>
<div class='div' style='background-color:#0c9157; margin: 35px 0 45px;'>
<div class='row'>
<div class='col-6'>
<h4 class='p-3 text-white'>Read It Now</h4>
</div>
<div class='col-6'>
<div class='float-right' style='position:absolute; transform:rotate(4deg); right:20%; top: -30px; box-shadow: 0px 0px 30px rgba(0, 0, 0, 0.5); -webkit-backface-visibility: hidden;'>
<img class="img-fluid" src="//cdn0.locable.com/uploads/resource/file/926693/fit/120x156/Riverton_SE_JUNE_40PAGES_PRINT_01_20copy.jpg?timestamp=1656690855" />
</div>
</div>
</div>
</div>
</a><div class='row'>
<div class='col text-center'>
<small>
<strong>
<div class='text-uppercase'><a style="color: #0c9157" href="https://www.rivertonjournal.com/archives">Archives</a></div>
</strong>
</small>

</div>
<div class='col text-center'>
<small>
<strong>
<div class='text-uppercase'><a style="color: #0c9157" href="https://issuu.com/mycityjournals/docs/riverton_newletter_se_june_web">Newsletter </a></div>
</strong>
</small>

</div>
</div>
</div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Riverton City Newsletter</h5>
<div style="position:relative;padding-top:max(60%,326px);height:0;width:100%"><iframe allow="clipboard-write" sandbox="allow-top-navigation allow-top-navigation-by-user-activation allow-downloads allow-scripts allow-same-origin allow-popups allow-modals allow-popups-to-escape-sandbox" allowfullscreen="true" style="position:absolute;border:none;width:100%;height:100%;left:0;right:0;top:0;bottom:0;" src="https://e.issuu.com/embed.html?d=riverton_newletter_se_june_web&u=mycityjournals"></iframe></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class="image-medium"><a href="https://secure.goemerchant.com/secure/custompayment/mycityjournals/3398/default.aspx"><img alt="" src="//cdn2.locable.com/uploads/resource/file/698693/fill/300x0/HELP_20SUPPORT_20_1_.png?timestamp=1585064588"></a></div><p>&nbsp;</p>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class="image-medium"><a href="https://visitor.r20.constantcontact.com/manage/optin?v=001iTDOE5WqIXkxQh0KtiP6H6B8BbHB4qfswqRgBcay-kHf68Em8lT99NPkA3atW6HRv683TfG2Ys8qhoXT0iulSps1bFNLzqU5AyttHKkL5Ac="><img alt="" src="//cdn0.locable.com/uploads/resource/file/514839/fill/300x0/Newsletter_20Sign_20Up.jpg?timestamp=1551725224"></a></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Follow The City Journals on Facebook</h5>
<div style="position:relative;padding-top:max(60%,326px);height:0;width:100%"><iframe sandbox="allow-top-navigation allow-top-navigation-by-user-activation allow-downloads allow-scripts allow-same-origin allow-popups allow-modals allow-popups-to-escape-sandbox" allowfullscreen="true" style="position:absolute;border:none;width:100%;height:100%;left:0;right:0;top:0;bottom:0;" src="https://e.issuu.com/embed.html?d=riverton_se_dec_web_cb52ac94c4bc64&u=mycityjournals"></iframe></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>South Valley Journal on Facebook</h5>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FSouthValleyJournal&amp;width=300&amp;height=590&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=true&amp;show_border=true&amp;appId=122882951100578" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:590px;" allowTransparency="true"></iframe>
</div>

</div>

</div>
</div>
</div>
<footer>
<section id='community-sponsor-footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>
</div>
</div>
</div>
</section>

<section id='footer-embed'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>

</div>
</div>
</div>
</section>
<section id='footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-12'>
<nav class='navbar navbar-expand-lg'>
<ul class='navbar-nav mr-auto simple-footer flex-wrap' style='white-space: nowrap;'>
<li class='category-134-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-134'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-425'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-636'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-423'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-776'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-101-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-101'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='category-104-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-104'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='calendar-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='calendar'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='d-lg-inline d-none directory-nav nav-item theme-menu-toggle' data-toggle='directory'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

</ul>
</nav>
</div>
</div>
</div>
</section>

<section id='copyright'>
<div class='container theme-shadow'>
<div class='row pt-3' style='padding-bottom: 50px;'>
<div class='col-12'>
<p class='text-muted small p-0 m-0'>
<span class='far fa-copyright'></span>
2022 | Powered by
<a target="_blank" class="text-muted" href="https://www.locablepublishernetwork.com?utm_source=attribution&amp;utm_medium=footer_credits&amp;utm_campaign=south-valley-journal">Locable</a>
|
<a target="_blank" class="text-muted" href="https://www.locablepublishernetwork.com/terms-of-use/">Terms of Service</a>
</p>
</div>
</div>
</div>
</section>

<section class='fixed-bottom' id='admin-bar'>
<nav>
<div class='d-none d-lg-flex'>
<div class='container'>
<ul class='nav justify-content-center px-3 mx-auto'>
<!-- = link_to image_tag('locable-l-icon.png', alt: 'Locable'), :root, class: 'navbar-brand hidden-xs' -->
<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>

</ul>
</div>
</div>
</nav>
</section>
</footer>
<div class='modal fade' id='welcome-modal' role='dialog' tabindex='-1'>
<div class='modal-dialog modal-lg' role='document'>
<div class='modal-content'></div>
</div>
</div>

<broadstreet-zone
        zone-id='popout'
        keywords='articles, article_riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery, south-valley-journal'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='popout'
                  keywords='articles, article_riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery, south-valley-journal'>
                  </broadstreet-zone>
<script src="//cdn1.locable.com/assets/application-39c5e61c733e5dae2abccb15635d17f38ac33ddc33724946895f526b4b05eadd.js"></script>
<script>
  window.s3DirectPostUrl = "https://locable-processing.s3.amazonaws.com/";
  window.s3DirectPostFields = {"AWSAccessKeyId":"AKIAJ6MRUF66HJSZBEVA","key":"uploads/d64d5c20-b0c1-4ae9-83c6-bce6873dd9e6/${filename}","policy":"eyJleHBpcmF0aW9uIjoiMjAyMi0wNy0wMVQxNjo1NDoxNVoiLCJjb25kaXRpb25zIjpbeyJidWNrZXQiOiJsb2NhYmxlLXByb2Nlc3NpbmcifSxbInN0YXJ0cy13aXRoIiwiJGtleSIsInVwbG9hZHMvZDY0ZDVjMjAtYjBjMS00YWU5LTgzYzYtYmNlNjg3M2RkOWU2LyJdLHsic3VjY2Vzc19hY3Rpb25fc3RhdHVzIjoiMjAxIn0seyJhY2wiOiJwdWJsaWMtcmVhZCJ9XX0=","signature":"zIHpb8gvQ6BvucPLOnaGV5LFnC8=","success_action_status":"201","acl":"public-read"};
</script>

<script src="https://static-v2.locablepublishernetwork.com/init-2.min.js" async="async"></script>
<script>
  window.broadstreet = window.broadstreet || { run: [] };
  window.broadstreet.run.push(function() {
    broadstreet.watch( {
      "autoAttach": {},
      "autoAttachAndWatch": {},
      "keywords": ["articles", "article_riverton-outpatient-facility-graduates-four-individuals-to-life-long-recovery", "south-valley-journal"],
      "networkId": "2402",
      "selector": 'broadstreet-zone',
      "softKeywords": true,
      "uriKeywords": false,
      "useZoneAliases": true,
      "useAltZone": 768,
      "domain": "sponsors-v2.locablepublishernetwork.com"
    });
  });
</script>

<script src="https://cdnjs.cloudflare.com/ajax/libs/jQuery.print/1.5.1/jQuery.print.min.js"></script>




<div id='fb-root'></div>
<script>
  window.addEventListener('scroll', () =>
    setTimeout(() => {
      (function(d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s); js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=122882951100578";
        fjs.parentNode.insertBefore(js, fjs);
      }(document, 'script', 'facebook-jssdk'));
    }, 1000),
    {once: true}
  );
</script>

<script>
  //= javascript_include_tag '//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52a6071c0ad9d295', async: true
  window.addEventListener('scroll', () =>
    setTimeout(() => {
      var script = document.createElement('script');
      script.type = 'text/javascript';
      script.src = "//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52a6071c0ad9d295";
      document.getElementsByTagName('head')[0].appendChild(script);
    }, 1000),
    {once: true}
  );
</script>

<script src='https://code.jquery.com/jquery-migrate-3.0.1.js' type='text/javascript'></script>

<script type="text/javascript">(function(){window['__CF$cv$params']={r:'724051b45fe56fad',m:'hWm6hpvO3FJea0UXcXqR0dbdpPZppMW_e8keNwJ.ia4-1656690855-0-ASXIinU75tbCUQUFAYQIhynd1yByRz2RQJupx+jpLD/gnT4Z47wAAueNi5l3BL9+3+SYZSG9eoJsOr5lVIeOBiZd7F5TjVABVyfDWq4Nm3n8G+ndIfXFvnDzuku/zYkr7qipmpALa9CHNikUHCZSVqKXwf2aLU8LqplCto3A35JrGEc6D0jzweS4ZsIxJOkbyT/GC3s3W2LNECWtF7cCwrSiFJ6vk6Ru1Qfb3yIjmMKiX/nCRK3nAC4hcqI/BtnPKw==',s:[0x926f88c6ca,0x7592092b5b],u:'/cdn-cgi/challenge-platform/h/b'}})();</script></body>
</html>
