<!DOCTYPE html>
<html lang='en'>
<head>
<title>‘What is a veteran?’ Riverton commemorates Veterans Day with guest speaker | South Valley Journal</title>
<meta charset='utf-8'>
<meta content='LocablePublisherNetwork.com' name='generator'>
<meta content='width=device-width, initial-scale=1' name='viewport'>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"cc2c1fbc9a","applicationID":"18721","transactionName":"IQwNRUJXWQhdEBdZRxYKAF1VSxoXUA1P","queueTime":4,"applicationTime":205,"agent":""}</script>
<script>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</script>
<meta content='122882951100578' property='fb:app_id'>
<meta property="og:title" content="‘What is a veteran?’ Riverton commemorates Veterans Day with guest speaker | South Valley Journal" /><meta name="description" content="Members of the Riverton community join to commemorate individuals and veterans who served in the military.  " /><meta property="og:description" content="Members of the Riverton community join to commemorate individuals and veterans who served in the military.  " /><meta property="og:type" content="article" /><meta property="og:image" content="http://locable-assets-production.s3.amazonaws.com/uploads/resource/file/871522/Brian_20McCoy_20Veterans_20Day_201.jpeg.jpg?timestamp=1638222872" /><meta property="og:image:width" content="3423" /><meta property="og:image:height" content="2283" /><link rel="canonical" href="https://www.rivertonjournal.com/2021/11/29/376560/-what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker" /><meta property="og:url" content="http://www.rivertonjournal.com/2021/11/29/376560/-what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker" /><meta name="keywords" content="Today, Local Life" /><meta name="ICMB" content="" />

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="YGnRXExvmRAKt9t05911REGdK5DamEuOhwkL9CyzZl2WidO1clADZ8k3nitG0uJ8548LNJNHhgd31C/XA9WZVQ==" />
<link rel="shortcut icon" type="image/x-icon" href="//cdn0.locable.com/uploads/favicon_img/file/39/CJ_Favicon-32x32.png" />
<link rel="stylesheet" media="screen" href="//cdn1.locable.com/assets/application-e9968553883ec0da0533edff74ff99b362e4b2e0ec5566d1c07106800206bcdd.css" />
<link rel="stylesheet" media="print" href="//cdn3.locable.com/assets/print-fe1b40859b2ebf3b0a55c395ad974b40f3dc0afb58a59f937c6ab67b342c3f65.css" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
</script>
<script>
  ga('create', 'UA-62910614-1', 'auto');
  ga('send', 'pageview');
</script>
<script>
  ga('create', 'UA-16494411-5', 'auto', {'name': 'rollup'});
  ga('rollup.send', 'pageview');
</script>
<style>
  .custom-header, .custom-header a {color: #ffffff !important; }.custom-header {background-color: #007051 !important; }.custom-header {text-align: center !important; }#main-nav .navbar-nav .nav-link, .classic-nav .navbar-brand .navbar-text, #main-nav .navbar-toggler span {color:  !important;} #main-nav .navbar-toggler {border-color:  !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {color: #ffffff !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {background-color: #007051 !important;}.public #main-nav .container, .dco #main-nav .container, .admin #main-nav, .admin #main-nav .container {background-color:  !important;}#main-nav .dropdown-item {color:  !important;}#main-nav .dropdown-item:hover {color:  !important;}#main-nav .dropdown-item:hover {background-color:  !important;}#main-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {color: #ffffff !important;}#secondary-nav .navbar-nav .nav-link:hover, #secondary-nav a:hover {color: #007051 !important;}#secondary-nav .navbar-nav .nav-link:hover, #seconary-nav a:hover {background-color: #ffffff !important;}#secondary-nav nav {background-color: #007051 !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {background-color:  !important;}#secondary-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {font-size: 1.2rem !important; line-height: 1.2rem; letter-spacing: 1.5px;}.col-menu li a, .simple-footer li a, #copyright p.text-muted a {color:  !important; }.col-menu li a:hover, .simple-footer li a:hover, #copyright p.text-muted a:hover {color: #007051 !important; }#footer p, #footer h6, #copyright p {color:  !important; }.places #copyright, .places #footer, #copyright .container, #footer .container {background-color:  !important; }
</style>
<style>
  
</style>
<meta name="google-site-verification" content="w4B26YBivWvg007bxK2P1YaQirePoFlddfNTpjCv7aM" />
<script async='' defer='defer' src='https://addevent.com/libs/atc/1.6.1/atc.min.js' type='text/javascript'></script>
</head>


<body class='classic-header public'>
<a class="sr-only" href="#content">Skip to main content</a>
<div class='fixed-top' data-toggle='affix'>
<section id='main-nav'>
<div class='container theme-shadow bg-white'>
<nav class='classic-nav navbar navbar-expand-lg navbar-light'>
<a class="navbar-brand" href="/"><span class='navbar-text fas fa-home' style='position:relative;top:2px'></span>
</a><button aria-controls='navbarContent' aria-expanded='false' aria-label='Toggle navigation' class='navbar-toggler' data-target='#navbarContent' data-toggle='collapse' type='button'>
<span class='fas fa-bars'></span>
</button>
<div class='collapse navbar-collapse' id='navbarContent'>
<ul class='navbar-nav mr-lg-auto' style='white-space: nowrap;'>
<li class='nav-item page-60529-nav'><a class="nav-link" href="/pages/aboutus">About Us</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-60537-nav'><a class="nav-link" href="/pages/advertise">Advertise</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-92573-nav'><a class="nav-link" href="/pages/rack-locations">Rack Locations</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-114340-nav'><a class="nav-link" href="/pages/more-journals">More Journals</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-60545-nav'><a class="nav-link" href="/pages/contactus">Contact Us</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-345206-nav'><a class="nav-link" href="/pages/write-for-us">Write For Us</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='external-link-231-nav nav-item'><a class="nav-link" href="https://www.rivertonjournal.com/archives">E-Edition</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<div class='dropdown-divider d-inline d-lg-none'></div>

<div class='d-lg-none'>
<li class='category-134-nav nav-item theme-menu-toggle' data-toggle='category-134'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav nav-item theme-menu-toggle' data-toggle='category-425'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav nav-item theme-menu-toggle' data-toggle='category-636'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav nav-item theme-menu-toggle' data-toggle='category-423'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav nav-item theme-menu-toggle' data-toggle='category-776'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-101-nav nav-item theme-menu-toggle' data-toggle='category-101'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='category-104-nav nav-item theme-menu-toggle' data-toggle='category-104'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='calendar-nav nav-item theme-menu-toggle' data-toggle='calendar'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='directory-nav nav-item theme-menu-toggle' data-toggle='directory'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

<div class='dropdown-divider'></div>
</div>
<div class='d-lg-none'>
<!-- = link_to image_tag('locable-l-icon.png', alt: 'Locable'), :root, class: 'navbar-brand hidden-xs' -->
<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>

<div class='dropdown-divider'></div>
</div>
</ul>
<ul class='navbar-nav ml-lg-auto'>
<ul class='list-inline social-links' style='white-space: nowrap;'>
<li class='list-inline-item mr-2'>
<a target="_blank" class="facebook" href="https://www.facebook.com/SouthValleyJournal/"><i class='fab fa-facebook fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="instagram" href="https://instagram.com/cityjournals"><i class='fab fa-instagram fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="linkedin" href="https://www.linkedin.com/company/city-journals/"><i class='fab fa-linkedin fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="twitter" href="https://twitter.com/SValleyJournal"><i class='fab fa-twitter fa-2x'></i>
</a></li>
<li class='list-inline-item mr-2'>
<a target="_blank" class="email" href="/pages/contactus"><i class='fas fa-envelope fa-2x'></i>
</a></li>
</ul>

<form class="form-inline" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" />
<div class='input-group'>
<label class="sr-only" for="q">Search</label>
<input type="text" name="q" id="q" placeholder="Search Site" class="form-control" />
<span class='input-group-btn'>
<button class='btn btn-secondary btn-search'>
<span class='sr-only'>Search</span>
<span class='fas fa-search'></span>
</button>
</span>
</div>
</form>


</ul>
</div>
</nav>
</div>
</section>
</div>

<section id='alerts'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>

</div>
</div>
</section>
<header>
<section id='masthead'>
<div class='container theme-shadow bg-white'>
<div class='row'>
<div class='col-12'>
<h1 class='p-3'><a href="/"><img alt="South Valley Journal" style="max-width: 100%;" src="//cdn3.locable.com/uploads/logo_image/file/412/CJ-Website_Riverton.png" /></a></h1>
</div>
</div>
</div>
</section>

<div class='d-none d-lg-inline'>
<section id='secondary-nav'>
<div class='container theme-shadow bg-white'>
<div class='row py-1'>
<div class='col-sm-12'>
<nav class='navbar navbar-expand-lg navbar-light'>
<!-- %ul#theme-navigation-tabdrop-menu.navbar-nav.mr-auto -->
<ul class='navbar-nav mr-auto flex-wrap' style='white-space: nowrap;'>
<!-- %li.pull-left -->
<!-- = link_to :root do -->
<!-- - if current_site.homepage.present? -->
<!-- = current_site.homepage -->
<!-- - else -->
<!-- %span.fa.fa-home{style: 'font-size:14px;position:relative;top:-1px'} -->
<li class='category-134-nav nav-item theme-menu-toggle' data-toggle='category-134'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav nav-item theme-menu-toggle' data-toggle='category-425'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav nav-item theme-menu-toggle' data-toggle='category-636'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav nav-item theme-menu-toggle' data-toggle='category-423'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav nav-item theme-menu-toggle' data-toggle='category-776'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-101-nav nav-item theme-menu-toggle' data-toggle='category-101'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='category-104-nav nav-item theme-menu-toggle' data-toggle='category-104'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='calendar-nav nav-item theme-menu-toggle' data-toggle='calendar'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='directory-nav nav-item theme-menu-toggle' data-toggle='directory'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

</ul>
</nav>
</div>
</div>
</div>
</section>

</div>
<section id='pushdown'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>
<div class='py-3'><broadstreet-zone
        zone-id='pushdown'
        keywords='articles, article_what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker, south-valley-journal'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='pushdown'
                  keywords='articles, article_what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker, south-valley-journal'>
                  </broadstreet-zone></div>
</div>
</div>
</section>
</header>
<div class='container theme-shadow bg-white' id='content'>
<div class='row'>
<div class='col-12 col-lg-8'>
<section id='admin-buttons'>
<div class='container'>
<div class='row'>
<div class='col-12'>
<div class='btn-group btn-group-sm'>
</div>
</div>
</div>
<div class='row py-2'>
<div class='col-12'>
</div>
</div>
</div>
</section>
<article>
<div class='container'>
<div class=''>
<div class='row py-3'>
<div class='col-12'>
<h1 class='py-0'>
‘What is a veteran?’ Riverton commemorates Veterans Day with guest speaker
</h1>
<span class='small text-muted'>
Nov 29, 2021 02:29PM
&#x25CF
By Dylan Wilcox
</span>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='images-contain'>
<img alt="" class="img-fluid" src="//cdn2.locable.com/uploads/resource/file/871522/fill/800x600/Brian_20McCoy_20Veterans_20Day_201.jpeg.jpg?timestamp=1638221406" />
</div>
<p class='h6 text-right'>
<small><p>Veteran Brian McCoy, guest speaker, addresses members of the Riverton community at the Sandra Lloyd Community Center on Nov. 11, 2021.  (Brook Bowen/Riverton City) <br></p></small>
</p>
</div>
</div>
<div class='d-flex justify-content-center'>
<div class='py-3 broadstreet'>
<broadstreet-zone
        zone-id='sponsored'
        keywords='articles, article_what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker, south-valley-journal'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='sponsored'
                  keywords='articles, article_what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker, south-valley-journal'>
                  </broadstreet-zone>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='clearfix images-contain images-thumbnails'>
<p><span>By Dylan Wilcox | <a href="/cdn-cgi/l/email-protection#1a7e346d73767975625a776379736e6370756f68747b766934797577"><span class="__cf_email__" data-cfemail="482c663f21242b27300825312b213c3122273d3a2629243b662b2725">[email&#160;protected]</span></a></span></p><p>Residents of Riverton City gathered in the Sandra N. Lloyd Community Center on Veterans Day to honor and commemorate individuals in the community who served in the military. Following the presentation of colors by the American Legion Post 140, Riverton City Mayor, Trent Staggs, welcomed the group of 200 people to the evening’s events.  </p><p>“We owe [our veterans] a debt of gratitude that I think can never be repaid,” Staggs said. Staggs introduced the keynote speaker, veteran Brian L McCoy, who served for five years in the Army. McCoy, a native of Four Corners, served a mission for The Church of Jesus Christ of Latter-day Saints in South Texas and then returned to Utah where he completed his undergraduate studies at BYU Provo. He and his wife Jan have nine children. Currently, McCoy practices law and is the Chair of Mexican-Latino Institute of Utah.</p><p>According to McCoy, he determined it would be better to enlist in the military by his own accord rather than being drafted so he could have more autonomy on his training and job assignments. “[I] opted for military intelligence since I had a degree in political science and spoke Spanish. I was then offered a slot in Officer Candidate School and graduated as a second lieutenant about a year after enlisting,” he said.</p><p>McCoy began his military service in 1970, shortly after the Vietnam War. Following extensive training, in 1972 McCoy was sent to the Panama Canal Zone where he learned various military techniques from demolition to parachuting. McCoy served as a military intelligence officer, which was part of a Special Forces company S2 and Special Forces A-Team Leader, a group who specialized in conventional and unconventional guerilla warfare. Their objective was to evacuate the United States Embassy in the case of an emergency, a situation that never transpired during his tour in Panama.</p><p>While in Panama, he and his fellow service members visited several remote villages which were only accessible by air drop or by boat. McCoy showed pictures of his tour to the audience. A photograph of a young Panamanian child flashed across the screen; McCoy joked that the child was a “confidential informant.”</p><p>“My military experience was invaluable,” McCoy said. “I learned things that I don’t think can be learned as well any other way: self-discipline, perseverance, physical conditioning, team work, loyalty, specialized skills, leadership, planning, and mission accomplishment. All of those things have stayed with me and made me a better father, citizen, lawyer and even church leader.”</p><p>After sharing with the audience a few pictures of his three-year-stint in Panama, McCoy focused on his fellow veterans. He offered them a moment of introspection by asking, “What is a veteran? How would you define or describe yourself?” He answered his rhetorical question by saying, “A veteran, in my mind, is someone who takes a stand.” McCoy referenced the Founding Fathers who signed the Declaration of Independence. Noting that their backgrounds varied in everything from age to social status, McCoy stated that despite their differences, the Founding Fathers were united in their desire for freedom.</p><p>“These men risked committing treason [against the British Crown] for the pursuit of liberty and freedom,” McCoy said. Following the American Revolutionary War and other similar conflicts, due to the efforts of soldiers, the United States began to etch itself into history books and eventually established independence. As the United States defined itself through the Declaration of Independence and the Constitution, the country’s dream is ongoing. Veterans serve as the “guardians” of the country, McCoy says.</p><p>McCoy encourages all citizens to be patriots and to stand up for the freedoms afforded to all Americans by the Constitution, which was created through the blood and sacrifice of early American patriots.</p><p>Under the direction of Bill Mattingly, the Riverton Jazz Band regaled the audience with renditions of jazz classics such as “In The Mood.” Vocalist Valaura Arnold performed two songs, “Blue Skies” and “Orange Colored Sky,” accompanied by the jazz band. Following Arnold’s performance, the band played “America the Beautiful” and “American Patrol,” followed by the anthem of each military branch. As each branch anthem was performed, veterans from the Army, Navy, Air Force, National Guard and Marine Corps stood to be recognized.</p><p>Melissa Sullivan, representing the Quilts of Valor Foundation, recognized the individual veterans who attended. Each of the veterans were presented a handmade quilt by the foundation. The Quilts of Valor Foundation has given out over 286,000 quilts to veterans across the country since 2003. </p><p>Sullivan referred to a quote by Arthur Ashe who said, “True heroism is remarkably sober, very undramatic. It is not the urge to surpass all others at whatever cost, but the urge to serve others at whatever cost.” She added, “This defines veterans for me and what they continue to do every day for our country.”</p><p>Jennifer Lee, board member for the Quilts of Valor Foundation, could not make it to the event, so Sullivan represented the foundation in her stead. The quilts were handmade by members of the community “to say thank you for your service and sacrifice in serving the nation,” Sullivan said.</p><p>Each veteran lined up to be recognized and was presented with their own unique quilt following the retirement of the colors.</p><p>Staggs gave closing remarks. “While we give thanks and honor [our veterans’] service, we must share the responsibility of protecting freedom here at home. We can do this, in part, by voting in elections, providing service to others, speaking out against those who would undermine our American values – the Constitution and the great ideals for which the country was founded – this is a work in progress.” Referencing former President Ronald Reagan who said freedom could be “a generation away from extinction,” Staggs encouraged those in attendance to fight and protect freedom.</p><p>“Thank you so much for your service and defending the liberty of this great nation in advancing freedom around the globe,” Staggs said. “No one understands the price of freedom more than those who have served our country,” he added.</p><p>Veterans Day, previously known as Armistice Day, marks the official end of World War I on Nov. 11, 1918.</p><p><br></p>
</div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='addthis_native_toolbox'></div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<span class='fas fa-tags' style='margin-right: 2px'></span>
<a style="color: #555" href="/categories/today">Today</a>, <a style="color: #555" href="/categories/local-life">Local Life</a>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='fb-comments' data-href='http://www.rivertonjournal.com/2021/11/29/376560/-what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker' data-width='100%'></div>
</div>
</div>
</div>
</div>
</article>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  var addthis_share = {
     url: "https://www.rivertonjournal.com/2021/11/29/376560/-what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker",
     title: "‘What is a veteran?’ Riverton commemorates Veterans Day with guest speaker",
     description: "Members of the Riverton community join to commemorate individuals and veterans who served in the military.",
     media: "//cdn1.locable.com/uploads/resource/file/871522/fill/1200x600/Brian_20McCoy_20Veterans_20Day_201.jpeg.jpg?timestamp=1638222872"
  }
</script>

</div>
<div class='col-12 col-lg-4'>

<div class='div' style='width: 300px; margin: auto;'>
<div class='images-sidebar my-3 clearfix'>
<div class='undecorate'>
<div class='my-3'>
<h5 class='px-3 py-2 custom-header'>Upcoming Events Near You</h5>
</div>
</div>
<div id='calendar-widget'>
<div class='undecorate'>
<div class='my-3'>
<a class="undecorate" href="/events/219487/mr-robinsons-christmas-carols-sing-along"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
1
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Mr. Robinson's Christmas Carols Sing-Along
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
6:00pm
&#183;
L. Clark Cushing Heritage Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/220085/sugar-factory-playhouse-a-gift-to-remember"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
2
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Sugar Factory Playhouse: A Gift to Remember
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
7:30pm
&#183;
Midvale Preforming Arts Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/220094/schorr-gallery-tony-hunter"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
2
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Schorr Gallery: Tony Hunter
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
8:00pm
&#183;
West Jordan City Hall
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/219991/wheeler-farm-festive-fridays"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
3
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Wheeler Farm Festive Fridays
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
7:00pm
&#183;
Murray Park Amphitheater
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/219992/wheeler-farm-festive-fridays"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
3
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Wheeler Farm Festive Fridays
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
7:00pm
&#183;
Murray Park Amphitheater
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/220086/sugar-factory-playhouse-a-gift-to-remember"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
3
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
Sugar Factory Playhouse: A Gift to Remember
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
7:30pm
&#183;
Midvale Preforming Arts Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/219901/elf-the-musical"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
3
</strong>
</div>
<div class='media-body ml-2'>
<h6>
<span class='text-uppercase text-danger'></span>
ELF the Musical
</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
7:30pm
&#183;
Hopebox Theatre
</div>
</div>
</div>
</div>
</div>
</div>
</a>
<div class='d-flex justify-content-center pb-3'>
<a class="btn btn-light" href="/calendar"><div class='fas fa-calendar-alt'></div>
View All
</a><a class="btn btn-light rounded-0" href="/events/new"><div class='fas fa-plus-circle'></div>
Add Your Event
</a></div>
</div>
</div>
</div>

</div>
<div class='images-sidebar my-3 clearfix'>
<div class='py-3 sidebar-current-issue'>
<a style="text-decoration: none" href="/2021/11/10/374476/in-this-issue-november-2021"><div class='row'>
<div class='col-12'>
<h3 class='text-uppercase' style='color:#0c9157'>
NOVEMBER
</h3>
</div>
</div>
<div class='div' style='background-color:#0c9157; margin: 35px 0 45px;'>
<div class='row'>
<div class='col-6'>
<h4 class='p-3 text-white'>Read It Now</h4>
</div>
<div class='col-6'>
<div class='float-right' style='position:absolute; transform:rotate(4deg); right:20%; top: -30px; box-shadow: 0px 0px 30px rgba(0, 0, 0, 0.5); -webkit-backface-visibility: hidden;'>
<img class="img-fluid" src="//cdn3.locable.com/uploads/resource/file/866991/fit/120x156/Riverton_SE_NOV_32PAGES_PRINT_01_20copy.jpg?timestamp=1638222872" />
</div>
</div>
</div>
</div>
</a><div class='row'>
<div class='col text-center'>
<small>
<strong>
<div class='text-uppercase'><a style="color: #0c9157" href="https://www.rivertonjournal.com/archives">Archives</a></div>
</strong>
</small>

</div>
<div class='col text-center'>
<small>
<strong>
<div class='text-uppercase'><a style="color: #0c9157" href="https://issuu.com/mycityjournals/docs/riverton_newsletter_se_nov_web">Newsletter </a></div>
</strong>
</small>

</div>
</div>
</div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Riverton City Newsletter</h5>
<div style="position:relative;padding-top:max(60%,326px);height:0;width:100%"><iframe sandbox="allow-top-navigation allow-top-navigation-by-user-activation allow-downloads allow-scripts allow-same-origin allow-popups allow-modals allow-popups-to-escape-sandbox" allowfullscreen="true" style="position:absolute;border:none;width:100%;height:100%;left:0;right:0;top:0;bottom:0;" src="https://e.issuu.com/embed.html?d=riverton_newsletter_se_nov_web&u=mycityjournals"></iframe></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class="image-medium"><a href="https://secure.goemerchant.com/secure/custompayment/mycityjournals/3398/default.aspx"><img alt="" src="//cdn2.locable.com/uploads/resource/file/698693/fill/300x0/HELP_20SUPPORT_20_1_.png?timestamp=1585064588"></a></div><p>&nbsp;</p>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class="image-medium"><a href="https://visitor.r20.constantcontact.com/manage/optin?v=001iTDOE5WqIXkxQh0KtiP6H6B8BbHB4qfswqRgBcay-kHf68Em8lT99NPkA3atW6HRv683TfG2Ys8qhoXT0iulSps1bFNLzqU5AyttHKkL5Ac="><img alt="" src="//cdn0.locable.com/uploads/resource/file/514839/fill/300x0/Newsletter_20Sign_20Up.jpg?timestamp=1551725224"></a></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Online Edition</h5>
<div style="position:relative;padding-top:max(60%,326px);height:0;width:100%"><iframe sandbox="allow-top-navigation allow-top-navigation-by-user-activation allow-downloads allow-scripts allow-same-origin allow-popups allow-modals allow-popups-to-escape-sandbox" allowfullscreen="true" style="position:absolute;border:none;width:100%;height:100%;left:0;right:0;top:0;bottom:0;" src="https://e.issuu.com/embed.html?d=riverton_se_nov_web_3e6ff2b7cd2830&u=mycityjournals"></iframe></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Follow The City Journals on Facebook</h5>
<div class="fb-page" data-href="https://www.facebook.com/The-City-Journals-1508669356040840/" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/The-City-Journals-1508669356040840/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/The-City-Journals-1508669356040840/">The City Journals</a></blockquote></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Follow The City Journals on Twitter</h5>
<a class="twitter-timeline" data-width="300" data-height="275" href="https://twitter.com/MyCityJournals?ref_src=twsrc%5Etfw">Tweets by MyCityJournals</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Follow The City Journals on LinkedIn</h5>
<div align="center" width="300" height="200"><script src="https://platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
<script type="IN/FollowCompany" data-id="18895884" data-counter="top"></script></div>

</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>South Valley Journal on Facebook</h5>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FSouthValleyJournal&amp;width=300&amp;height=590&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=true&amp;show_border=true&amp;appId=122882951100578" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:590px;" allowTransparency="true"></iframe>
</div>

</div>

</div>
</div>
</div>
<footer>
<section id='community-sponsor-footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>
<h4 class='text-center mb-5'>
BROUGHT TO YOU BY OUR COMMUNITY SPONSORS
</h4>
<div class='community-sponsors-grid'>
<div class='row justify-content-center'>
<div class='col-sm-2 col-6'>
<div class='undecorate'>
<a href="/businesses/ut-salt-lake-city-rooter-connectionz"><img class="img-fluid" src="//cdn2.locable.com/uploads/resource/file/804060/fit/160x100/NEW_20LOGO_202019_20MAY-page-001.jpg?timestamp=1638222872" />
<p class='small text-center text-muted'>Rooter Connectionz</p>
</a></div>
</div>
<div class='col-sm-2 col-6'>
<div class='undecorate'>
<a href="/businesses/ut-riverton-larkin-mortuary"><img class="img-fluid" src="//cdn0.locable.com/uploads/resource/file/770550/fit/160x100/larkin.jpg?timestamp=1638222872" />
<p class='small text-center text-muted'>Larkin Mortuary</p>
</a></div>
</div>
<div class='col-sm-2 col-6'>
<div class='undecorate'>
<a href="/businesses/ut-salt-lake-city-action-plumbing"><img class="img-fluid" src="//cdn2.locable.com/uploads/resource/file/804069/fit/160x100/ActionLogo2014.jpg?timestamp=1638222872" />
<p class='small text-center text-muted'>Action Plumbing</p>
</a></div>
</div>
</div>
</div>

</div>
</div>
</div>
</section>

<section id='footer-embed'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>

</div>
</div>
</div>
</section>
<section id='footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-12'>
<nav class='navbar navbar-expand-lg'>
<ul class='navbar-nav mr-auto simple-footer flex-wrap' style='white-space: nowrap;'>
<li class='category-134-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-134'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/news">News
<b class='caret'></b>
</a></li>
<li class='category-425-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-425'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/sports">Sports
<b class='caret'></b>
</a></li>
<li class='category-636-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-636'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/local-life">Local Life
<b class='caret'></b>
</a></li>
<li class='category-423-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-423'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/education">Education
<b class='caret'></b>
</a></li>
<li class='category-776-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-776'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/business">Business
<b class='caret'></b>
</a></li>
<li class='category-101-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-101'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/arts-entertainment">Arts+Entertainment
<b class='caret'></b>
</a></li>
<li class='category-104-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='category-104'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/categories/food-dining">Food+Dining
<b class='caret'></b>
</a></li>
<li class='calendar-nav d-lg-inline d-none nav-item theme-menu-toggle' data-toggle='calendar'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/calendar">Calendar
<b class='caret'></b>
</a></li>
<li class='d-lg-inline d-none directory-nav nav-item theme-menu-toggle' data-toggle='directory'>
<!-- = link_to category_path(article_category.permalink) do -->
<a class="nav-link" href="/businesses">Directory
<b class='caret'></b>
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

</ul>
</nav>
</div>
</div>
</div>
</section>

<section id='copyright'>
<div class='container theme-shadow'>
<div class='row pt-3' style='padding-bottom: 50px;'>
<div class='col-12'>
<p class='text-muted small p-0 m-0'>
<span class='far fa-copyright'></span>
2021 | Powered by
<a target="_blank" class="text-muted" href="https://www.locablepublishernetwork.com?utm_source=attribution&amp;utm_medium=footer_credits&amp;utm_campaign=south-valley-journal">Locable</a>
|
<a target="_blank" class="text-muted" href="https://www.locablepublishernetwork.com/terms-of-use/">Terms of Service</a>
</p>
</div>
</div>
</div>
</section>

<section class='fixed-bottom' id='admin-bar'>
<nav>
<div class='d-none d-lg-flex'>
<div class='container'>
<ul class='nav justify-content-center px-3 mx-auto'>
<!-- = link_to image_tag('locable-l-icon.png', alt: 'Locable'), :root, class: 'navbar-brand hidden-xs' -->
<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>

</ul>
</div>
</div>
</nav>
</section>
</footer>
<div class='modal fade' id='welcome-modal' role='dialog' tabindex='-1'>
<div class='modal-dialog modal-lg' role='document'>
<div class='modal-content'></div>
</div>
</div>

<broadstreet-zone
        zone-id='popout'
        keywords='articles, article_what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker, south-valley-journal'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='popout'
                  keywords='articles, article_what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker, south-valley-journal'>
                  </broadstreet-zone>
<script src="//cdn1.locable.com/assets/application-39c5e61c733e5dae2abccb15635d17f38ac33ddc33724946895f526b4b05eadd.js"></script>
<script>
  window.s3DirectPostUrl = "https://locable-processing.s3.amazonaws.com/";
  window.s3DirectPostFields = {"AWSAccessKeyId":"AKIAJ6MRUF66HJSZBEVA","key":"uploads/95575f6e-9199-4a32-8f25-0ea1d1d712f4/${filename}","policy":"eyJleHBpcmF0aW9uIjoiMjAyMS0xMS0yOVQyMjo1NDozMloiLCJjb25kaXRpb25zIjpbeyJidWNrZXQiOiJsb2NhYmxlLXByb2Nlc3NpbmcifSxbInN0YXJ0cy13aXRoIiwiJGtleSIsInVwbG9hZHMvOTU1NzVmNmUtOTE5OS00YTMyLThmMjUtMGVhMWQxZDcxMmY0LyJdLHsic3VjY2Vzc19hY3Rpb25fc3RhdHVzIjoiMjAxIn0seyJhY2wiOiJwdWJsaWMtcmVhZCJ9XX0=","signature":"vS6Lx+lNVtMu2vhqVLJc3pqaix8=","success_action_status":"201","acl":"public-read"};
</script>

<script src="https://static-v2.locablepublishernetwork.com/init-2.min.js" async="async"></script>
<script>
  window.broadstreet = window.broadstreet || { run: [] };
  window.broadstreet.run.push(function() {
    broadstreet.watch( {
      "autoAttach": {},
      "autoAttachAndWatch": {},
      "keywords": ["articles", "article_what-is-a-veteran-riverton-commemorates-veterans-day-with-guest-speaker", "south-valley-journal"],
      "networkId": "2402",
      "selector": 'broadstreet-zone',
      "softKeywords": true,
      "uriKeywords": false,
      "useZoneAliases": true,
      "useAltZone": 768,
      "domain": "sponsors-v2.locablepublishernetwork.com"
    });
  });
</script>

<script src="https://cdnjs.cloudflare.com/ajax/libs/jQuery.print/1.5.1/jQuery.print.min.js"></script>




<div id='fb-root'></div>
<script>
  window.addEventListener('scroll', () =>
    setTimeout(() => {
      (function(d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s); js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=122882951100578";
        fjs.parentNode.insertBefore(js, fjs);
      }(document, 'script', 'facebook-jssdk'));
    }, 1000),
    {once: true}
  );
</script>

<script>
  //= javascript_include_tag '//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52a6071c0ad9d295', async: true
  window.addEventListener('scroll', () =>
    setTimeout(() => {
      var script = document.createElement('script');
      script.type = 'text/javascript';
      script.src = "//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52a6071c0ad9d295";
      document.getElementsByTagName('head')[0].appendChild(script);
    }, 1000),
    {once: true}
  );
</script>

<script src='https://code.jquery.com/jquery-migrate-3.0.1.js' type='text/javascript'></script>

</body>
</html>
